您当前的位置:首页 > 电脑百科 > 网络技术 > 网络设置

OSPF路由动态协议及配置

时间:2019-11-06 15:59:21  来源:  作者:

OSPF(Open Shortest Path First), 开放最短路径优先协议,是一种开源的使用最短路径优先(SPF)算法的内部网关协议(IGP)。常用于路由器的动态选路。

1、OSPF仅传播对端设备不具备的路由信息,网络收敛迅速,并有效避免了网络资源浪费;

2、OSPF直接工作于IP层之上,IP协议号为89;

3、OSPF以组播地址发送协议包;

OSPF工作原理

「案例」OSPF路由动态协议及配置

 

1、邻居(Neighbor):宣告OSPF的路由器从所有启动OSPF协议的接口上发出Hello数据包。

「案例」OSPF路由动态协议及配置

 

2、邻接关系(Adjacency):两台邻居路由器之间构成的一条点到点的虚链路,邻接关系的建立是由交换hello信息的路由器类型和网络类型决定的。

「案例」OSPF路由动态协议及配置

 

3、链路状态通告(Link State Advertisement,LSA):每一台路由器都会在所有形成邻接关系的邻居之间发送链路状态通告LSA。LSA描述了路由器所有的链路、接口、邻居等信息。ospf定义了许多不同的LSA类型。

「案例」OSPF路由动态协议及配置

 


「案例」OSPF路由动态协议及配置

 

4、链路状态数据库(LSDB):每一台收到来自邻居路由器发出的LSA的路由器都会把这些LSA信息记录在它的LSDB中,并且发送一份LSA的拷贝给该路由器的其他所有邻居。这样当LSA传播到整个区域后,区域内所有的路由器都会形成同样的LSDB。

「案例」OSPF路由动态协议及配置

 

DR和BDR选举

「案例」OSPF路由动态协议及配置

 

DR,BDR选举规则总结:

1、选举接口优先级,优先级越大越优先,被选DR,优先级第二,被选BDR。

2、如果优先级一样,选route-id,越大优先。

3、如果路由器没有设置route-id,那么选接口的ip地址,越大越优先。

注意:一个单区域中可以没有BDR,但是必须有DR!

OSPF配置案例

「案例」OSPF路由动态协议及配置

 

1、网络中包含三台路由器及两台PC;

2、为了能够更直观的观察到实验现象,每台路由器创建Loopback0接口,为该接口配置x.x.x.x/32的IP地址,并将该地址作为路由器的OSPF Router-ID。以R1为例,其Loopback0接口的IP地址为1.1.1.1/32。

3、需注意路由器的接口被规划在哪一个area中。R2是ABR,其两个接口接入不同的OSPF区域。

4、设备的接口编号及IP地址规划如图所示。

实验需求

1、完成三台路由器的基础配置,并在路由器上运行OSPF,使得全网路由互通;

2、完成两台PC的配置;

3、完成配置后,两台PC要能够互相ping通。

实现步骤及配置

R1的配置如下:

<Huawei>system-view
[Huawei]sy
[Huawei]sysname R1
[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.12.1 24
[R1-GigabitEthernet0/0/0]q
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.254 24
[R1-GigabitEthernet0/0/1]q
[R1]interface LoopBack 0
[R1-LoopBack0]ip address 1.1.1.1 32
[R1-LoopBack0]q
[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 192.168.12.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255

R2的配置如下:

<Huawei>system-view
[Huawei]sysname R2
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.12.2 24
[R2-GigabitEthernet0/0/0]q
[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 192.168.23.2 24
[R2-GigabitEthernet0/0/1]q
[R2]interface LoopBack 0
[R2-LoopBack0]ip address 2.2.2.2 32
[R2-LoopBack0]q
[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 192.168.12.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]q
[R2-ospf-1]area 1
[R2-ospf-1-area-0.0.0.1]network 192.168.23.0 0.0.0.255

R3的配置如下:

<Huawei>system-view
[Huawei]sysname R3
[R3]interface GigabitEthernet 0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.23.3 24
[R3-GigabitEthernet0/0/0]q
[R3]interface GigabitEthernet 0/0/1
[R3-GigabitEthernet0/0/1]ip address 192.168.2.254 24
[R3-GigabitEthernet0/0/1]q
[R3]interface LoopBack 0
[R3-LoopBack0]ip add
[R3-LoopBack0]ip address 3.3.3.3 32
[R3-LoopBack0]q
[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]area 1
[R3-ospf-1-area-0.0.0.1]network 192.168.2.0 0.0.0.255
[R3-ospf-1-area-0.0.0.1]network 192.168.23.0 0.0.0.255

完成配置后,请自行检查OSPF邻居关系,以及每台路由器的路由表,确保每台设备都学习到了全网各个网段的路由。此时PC1与PC2即可互相ping通。

「案例」OSPF路由动态协议及配置

 



Tags:OSPF   点击:()  评论:()
声明:本站部分内容及图片来自互联网,转载是出于传递更多信息之目的,内容观点仅代表作者本人,如有任何标注错误或版权侵犯请与我们联系,我们将及时更正、删除,谢谢。
▌相关推荐
在学习OSPF邻接关系前需要先了解OSPF的几种接口状态及邻居状态。1.OSPF路由器接口状态以太网中OSPF路由器接口状态分为6种:1、 Down状态,运行OSPF的接口初始化的状态。Down接...【详细内容】
2020-12-25  Tags: OSPF  点击:(59)  评论:(0)  加入收藏
一、网络拓扑 二、 OSPF关键配置R1 OSPF配置:router ospf 1router-id 1.1.1.1network 10.1.12.0 0.0.0.255 area 0network 12.1.1.0 0.0.0.255 area 0network 192.168.10.0 0...【详细内容】
2020-09-02  Tags: OSPF  点击:(112)  评论:(0)  加入收藏
FRRouting(FRR)简介FRR 是一个路由软件套件,它衍生自 Quagga,并在 GNU GPL2 许可下分发。与 Quagga 一样,它为类 Unix 平台提供了所有主要路由协议的实现,例如 OSPF、 路由信息协...【详细内容】
2020-06-03  Tags: OSPF  点击:(378)  评论:(0)  加入收藏
组网拓扑 组网相关及分值1、在10.0.0.0/24内自行规划互联和回环IP地址,其中互联地址掩码30位,环回地址掩码32位并指定router ID(27分);2、PC1-PC3属于不同VLAN,vlan号可自行确定;A...【详细内容】
2020-05-16  Tags: OSPF  点击:(107)  评论:(0)  加入收藏
1 配置需求或说明1.1适用产品系列本案例适用于如S7506E 、S5130S-28S-SI、S5500V2-24P-WiNet等支持OSPF协议的V7交换机。1.2配置需求SWA、SWB、SWC、SWD都运行OSPF,并将整个...【详细内容】
2020-03-08  Tags: OSPF  点击:(74)  评论:(0)  加入收藏
一、OSPF简介OSPF(Open Shortest Path First,开放最短路径优先)是 IETF(Internet Engineering Task Force,互联网工程任务组)组织开发的一个基于链路状态的内部网关协议。目前针对...【详细内容】
2020-03-05  Tags: OSPF  点击:(59)  评论:(0)  加入收藏
一、OSPF HelloA、OSPF Hello协议的目的:1.用于发现邻居2.在成为邻居之前,必须对Hello包里的一些参数协商成功3.Hello包在邻居之间扮演着keepalive的角色4.允许邻居之间的双...【详细内容】
2019-11-18  Tags: OSPF  点击:(61)  评论:(0)  加入收藏
一、多区域 OSPF在一个大型 OSPF 网络中,SPF 算法的反复计算,庞大的路由表和拓扑表的维护以及 LSA的泛洪等都会占用路由器的资源,因而会降低路由器的运行效率。OSPF 协议可以利...【详细内容】
2019-11-14  Tags: OSPF  点击:(81)  评论:(0)  加入收藏
OSPF(Open Shortest Path First), 开放最短路径优先协议,是一种开源的使用最短路径优先(SPF)算法的内部网关协议(IGP)。常用于路由器的动态选路。1、OSPF仅传播对端设备不具备的...【详细内容】
2019-11-06  Tags: OSPF  点击:(91)  评论:(0)  加入收藏
一 、OSPF原理及配置​OSPF(Open Shortest Pass First,开放最短路径优先协议),是一个最常用的内部网关协议,是一个链路状态协议。二 、OSPF的特点 OSPF是一种无类路由协议,支持VL...【详细内容】
2019-11-01  Tags: OSPF  点击:(118)  评论:(0)  加入收藏
▌简易百科推荐
有没有想过现在的路由器怎么都要设置2.4G和5G两个无线信号,让用户自己选择,智能点不好吗?其实,这种状况的存在,是路由器厂家面对现有网络状况和无线终端实际所做的妥协。目前的网...【详细内容】
2021-06-29  发呆学研    Tags:路由器   点击:(16)  评论:(0)  加入收藏
一、组网需求通过SSH功能远程管理设备。二、组网拓扑 三、配置要点1、需要开启SSH功能2、需要手工生成Key3、如果PC与交换机不在同一个网段,需要配置交换机的默认网关四、配...【详细内容】
2021-06-25  网络小伙儿  今日头条  Tags:锐捷交换机   点击:(52)  评论:(0)  加入收藏
一、组网需求配置telnet和SSH登陆时调用AAA列表。二、组网拓扑 三、配置要点1、该配置是在已经可以正常telnet、SSH到交换机的前提下配置的2、配置AAA本地认证;3、配置AAA ra...【详细内容】
2021-06-25  网络小伙儿  今日头条  Tags:radius认证   点击:(26)  评论:(0)  加入收藏
今天粉丝说公司现在有两台服务器,分别是web(server1)和ftp(server2),局域网有两个网段,要求这两个网段不能互访,而且都要访问web服务器,但是不能访问ftp服务器。需要帮助解决,后来我建...【详细内容】
2021-06-25  高工  今日头条  Tags:华为S5700   点击:(48)  评论:(0)  加入收藏
一、组网需求外网接口使用专线,由运营商分配指定的静态地址,内网为192.168.1.0/24网段,实现基本上网功能。 二、网络拓扑 假设运营商分配的地址如下:网段: 202.1.1.8/29分配ip地...【详细内容】
2021-06-24  网络小伙儿    Tags:静态地址   点击:(16)  评论:(0)  加入收藏
华为、H3C、CISCO三家交换机配置命令详解,这里对命令做了个汇总,平时对命令不熟的朋友这次可以看下。取消、关闭当前设置CISCO:noH3C:undoHUAWEI:undo 显示查看CISCO:showH3C:di...【详细内容】
2021-06-21  海沃网络    Tags:交换机配置   点击:(22)  评论:(0)  加入收藏
基础配置 1思科设备管理基础命令 enable 从用户模式进入特权模式configure terminal 进入配置模式interface g0/0 进入千兆以太网接口g0/0ip address 172.16.0.1 255.255.0....【详细内容】
2021-06-04  二方110  今日头条  Tags:思科   点击:(41)  评论:(0)  加入收藏
一、设备的几个调试模式使用console线,连接到锐捷路由器后,开始配置Telnet服务,在配置之前,先和大家讲解一下,配置命令主要的几个用户模式。 用户模式:用户模式下,当交换机加电启...【详细内容】
2021-05-14  IT小技术  今日头条  Tags:配置telnet   点击:(114)  评论:(0)  加入收藏
可能很多人都对程序猿(程序员)的工作充满了好奇,觉得程序员每天就是在趴在电脑前狂写代码,写的什么反正我们没几个人能看得懂,总是给人一种神秘感! 据说,程序员用的电脑配置的确是...【详细内容】
2021-05-13  隔壁家老王  今日头条  Tags:电脑网速   点击:(92)  评论:(0)  加入收藏
如何构建一个简单稳定可靠高速的家庭网络系统就成为了很多人所关心的问题,特别是对于一些准备买房装修或是已经装修好了准备安装网络设备的朋友,希望这篇文章能对你们有所帮助...【详细内容】
2021-05-06    中关村在线  Tags:布线   点击:(61)  评论:(0)  加入收藏
最新更新
栏目热门
栏目头条