您当前的位置:首页 > 电脑百科 > 网络技术 > 网络硬件

华为S5700交换机如何配置链路聚合

时间:2019-09-09 13:47:49  来源:  作者:

配置手工负载分担模式链路聚合示例

组网需求

如图1所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。

用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

图1 配置手工负载分担模式链路聚合组网图

华为S5700交换机如何配置链路聚合

 

配置思路

采用如下的思路配置负载分担链路聚合:

创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。

说明:

接口缺省都加入了VLAN1,因此加入Eth-Trunk前建议先将接口从VLAN1中退出或将接口Shutdown,避免出现广播风暴。

创建VLAN并将接口加入VLAN。

配置负载分担方式,实现流量在Eth-Trunk各成员接口间的负载分担,增加可靠性。

操作步骤

在SwitchA创建Eth-Trunk接口并加入成员接口。SwitchB配置与SwitchA类似,不再赘述。

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3

[SwitchA-Eth-Trunk1] quit

创建VLAN并将接口加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

# 创建VLAN10和VLAN20并分别加入接口。

[SwitchA] vlan batch 10 20

[SwitchA] interface gigabitethernet 0/0/4

[SwitchA-GigabitEthernet0/0/4] port link-type trunk

[SwitchA-GigabitEthernet0/0/4] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet0/0/4] quit

[SwitchA] interface gigabitethernet 0/0/5

[SwitchA-GigabitEthernet0/0/5] port link-type trunk

[SwitchA-GigabitEthernet0/0/5] port trunk allow-pass vlan 20

[SwitchA-GigabitEthernet0/0/5] quit

# 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] port link-type trunk

[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20

配置Eth-Trunk1的负载分担方式。SwitchB配置与SwitchA类似,不再赘述。

[SwitchA-Eth-Trunk1] load-balance src-dst-mac

[SwitchA-Eth-Trunk1] quit

配置LACP模式的链路聚合示例

组网需求

如图1所示,在两台Switch设备上配置LACP模式链路聚合组,提高两设备之间的带宽与可靠性,具体要求如下:

两条活动链路具有负载分担的能力。

两设备间的链路具有1条冗余备份链路,当活动链路出现故障链路时,备份链路替代故障链路,保持数据传输的可靠性。

图1 配置LACP模式链路聚合组网图

华为S5700交换机如何配置链路聚合

 

配置思路

采用如下的思路配置LACP模式链路聚合:

创建Eth-Trunk,配置Eth-Trunk为LACP模式,实现链路聚合功能。

将成员接口加入Eth-Trunk。

说明:

接口缺省都加入了VLAN1,因此加入Eth-Trunk前建议先将接口从VLAN1中退出或将接口Shutdown,避免出现广播风暴。

配置系统优先级,确定主动端,按照主动端设备的接口选择活动接口。

配置活动接口上限阈值,实现保证带宽的情况下提高网络的可靠性。

配置接口优先级,确定活动链路接口,优先级高的接口将被选作活动接口。

操作步骤

在SwitchA上创建Eth-Trunk1并配置为LACP模式。SwitchB配置过程与SwitchA类似,不再赘述

<HUAWEI> system-view

[HUAWEI] sysname SwitchA

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] mode lacp

[SwitchA-Eth-Trunk1] quit

配置SwitchA上的成员接口加入Eth-Trunk。SwitchB配置过程与SwitchA类似,不再赘述

[SwitchA] interface gigabitethernet 0/0/1

[SwitchA-GigabitEthernet0/0/1] eth-trunk 1

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface gigabitethernet 0/0/2

[SwitchA-GigabitEthernet0/0/2] eth-trunk 1

[SwitchA-GigabitEthernet0/0/2] quit

[SwitchA] interface gigabitethernet 0/0/3

[SwitchA-GigabitEthernet0/0/3] eth-trunk 1

[SwitchA-GigabitEthernet0/0/3] quit

在SwitchA上配置系统优先级为100,使其成为LACP主动端

[SwitchA] lacp priority 100

在SwitchA上配置活动接口上限阈值为2

[SwitchA] interface eth-trunk 1

[SwitchA-Eth-Trunk1] max active-linknumber 2

[SwitchA-Eth-Trunk1] quit

在SwitchA上配置接口优先级确定活动链路

[SwitchA] interface gigabitethernet 0/0/1

[SwitchA-GigabitEthernet0/0/1] lacp priority 100

[SwitchA-GigabitEthernet0/0/1] quit

[SwitchA] interface gigabitethernet 0/0/2

[SwitchA-GigabitEthernet0/0/2] lacp priority 100

[SwitchA-GigabitEthernet0/0/2] quit



Tags:交换机   点击:()  评论:()
声明:本站部分内容来自互联网,转载是出于传递更多信息之目的,内容观点仅代表作者本人,如有任何标注错误或版权侵犯请与我们联系,我们将及时更正、删除,谢谢。
▌相关评论
发表评论 共有条评论
用户名: 密码:
验证码: 匿名发表
▌相关推荐
当我们收到一个快递以后会发现在物品的最上面有地址信息,这是为了便于快递员通过简单的操作就可以看到要送到哪里。不光有目的地址,还有源地&mdash;&mdash;甚至还有内容物的类...【详细内容】
2020-07-04   交换机  点击:(0)  评论:(0)  加入收藏
一、交换机访问控制安全配置 1、对交换机特权模式设置密码尽量采用加密和md5 hash方式switch(config)#enable secret 5 pass_string其中 0 Specifies an UNENCRYPTED passwo...【详细内容】
2020-07-03   交换机  点击:(1)  评论:(0)  加入收藏
各位做网络的小伙伴有时候会遇到需要抓取交换机的配置文件。根据不同厂家,我们通常使用show run或者display cu等命令来进行配置文件的查看,然后再辅以SecureCRT等SSH工具将回...【详细内容】
2020-06-22   交换机  点击:(1)  评论:(0)  加入收藏
来自市场研究公司Dell&#39;Oro Group的最新报告称,全球园区交换机市场收入六年来首次出现下滑,该市场在2020年第一季度同比下降了6%。所有供应商都普遍表现疲软,包括思科、华为...【详细内容】
2020-06-16   交换机  点击:(3)  评论:(0)  加入收藏
交换机的某个端口的实时速率?占了端口总速率的百分比?是否拥塞了?这些都是网络管理工作中经常碰到的问题。大型企业通常是搭建基于snmp的网络管理系统。像SolarWinds、IMC、PRT...【详细内容】
2020-06-16   交换机  点击:(12)  评论:(0)  加入收藏
在交换机组网时常见的故障比较多,为了帮助大家更好地排除这些故障,在此介绍一些常见的典型故障案例和处理思路供大家参考。 1、 硬件故障2、 物理线路故障连接交换机的物理线...【详细内容】
2020-06-09   交换机  点击:(5)  评论:(0)  加入收藏
基本概念Access类型的端口只能属于1个VLAN,一般用于连接计算机的端口; Trunk类型的端口可以允许多个VLAN通过,可以接收和发送多个VLAN的报文,一般用于交换机之间连接的端口;处理...【详细内容】
2020-06-06   交换机  点击:(3)  评论:(0)  加入收藏
企业网用户的IP为10.0.0.2/24,通过Switch连接Internet。Switch为运营商设备。企业网用户只租用了1Mbps的上行带宽和2Mbps的下行带宽。 图1 普通CAR配置组网 配置思路流量监...【详细内容】
2020-06-06   交换机  点击:(14)  评论:(0)  加入收藏
1 链路聚合特性介绍1.1 背景随着网络规模不断扩大,用户对骨干链路的带宽和可靠性提出越来越高的要求。在传统技术中,常用更换高速率的接口板或更换支持高速率接口板的设备的方...【详细内容】
2020-06-04   交换机  点击:(9)  评论:(0)  加入收藏
什么?小编我几日不在江湖,江湖就传闻小伙伴们登录交换机时对密码惆怅得很,还传闻小伙伴们疑问最多的是:交换机的缺省密码都是什么呢???忘记密码了肿么办???小编我来也,瞬间变身诸葛神人...【详细内容】
2020-06-03   交换机  点击:(5)  评论:(0)  加入收藏
配置NAC认证 Voice VLAN实现IP话机接入交换机示例NAC认证 Voice VLAN介绍网络中经常有数据、语音、视频等多种流量同时传输。因为丢包和时延对通话质量的影响很大,用户对语音...【详细内容】
2020-05-28   交换机  点击:(2)  评论:(0)  加入收藏
(一)实验拓扑及需求 1. PC1属于VLAN10;PC2属于VLAN20;PC的IP地址见上图;2. 交换机Vlanif10及Vlanif20作为VLAN10及VLAN20用户的网关,地址为.254;3. 交换机使用vlan100与R1对接,vlani...【详细内容】
2020-05-20   交换机  点击:(6)  评论:(0)  加入收藏
“ 数据中心”作为新基建七大领域之一,可以有效促进云计算、大数据等技术的应用落地,同时创造出更加丰富、更具活力的应用形式。网络系统建设作为数据中心的“中枢神经”,所承...【详细内容】
2020-05-19   交换机  点击:(5)  评论:(0)  加入收藏
问题描述某客户支队下辖3个单位需要做IP地址绑定1大队:xx.xx.xx.101-121 绑定1口 2大队:xx.xx.xx.122-142 绑定2口 3大队:xx.xx.xx.143-163 绑定3口要求每个单位只能使用分配...【详细内容】
2020-05-18   交换机  点击:(12)  评论:(0)  加入收藏
■ 任务描述某服务器间的物理连接如图1所示,服务器A、B、C需要通过交换机与对端的服务器D、E、F通信,现需拓展链路带宽、同时提升服务器间访问的可靠性,传统的方式是更换更高级...【详细内容】
2020-05-18   交换机  点击:(7)  评论:(0)  加入收藏
昨天我们发了华为交换机配置的常用命令,今天再给大家发一下华三交换机的配置命令以及案例解析,希望对大家有所帮助。正文:为了让大家更加清楚,每行代码都有解释。一、系统IP配置...【详细内容】
2020-05-17   交换机  点击:(16)  评论:(0)  加入收藏
问题描述某客户支队下辖3个单位需要做IP地址绑定1大队:xx.xx.xx.101-121 绑定1口 2大队:xx.xx.xx.122-142 绑定2口 3大队:xx.xx.xx.143-163 绑定3口要求每个单位只能使用分配...【详细内容】
2020-05-16   交换机  点击:(6)  评论:(0)  加入收藏
什么是VLAN VLAN(virtual LAN)虚拟局域网是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,同一VLAN设备相互之间的...【详细内容】
2020-05-14   交换机  点击:(5)  评论:(0)  加入收藏
SW1配置[SW1]stp priority 4096[SW1-GigabitEthernet0/0/24]stp root-protectionSW2配置[SW2]stp priority 8192[SW2-GigabitEthernet0/0/24]stp edged-port enable[SW2-G...【详细内容】
2020-05-13   交换机  点击:(2)  评论:(0)  加入收藏
现在的监控设备用的地方越来越多,本文主要介绍简单的监控接入中交换机配置方法。当我们拿到设备后,首先需要进行监控设备的网络规划,可以按照物理位置、功能等划分监控的网段。...【详细内容】
2020-05-06   交换机  点击:(7)  评论:(0)  加入收藏
最新更新
栏目热门
栏目头条